Investigating issues with Credit Card Processing

Incident Report for producersnational

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 15:37 CDT

Investigating

We’re currently investigating reports of a potential service interruption with Credit Card Processing. We apologize for any inconvenience and will post another update as soon as we learn more.

Thank you!
Posted Jun 03, 2026 - 13:42 CDT
This incident affected: Credit Card Processing.