Phone System Issue

Incident Report for producersnational

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 16:05 CDT

Identified

Teams are working to restore call handling rules for some customers that may still be affected by this issue.
Posted Jul 10, 2025 - 11:54 CDT

Investigating

A portion of customers may be experiencing inbound calling issues.
Posted Jul 10, 2025 - 09:23 CDT
This incident affected: PhoneLines.